Price: (as of – Details) Letscom Fitness Tracker with Heart Rate Monitor This tracker requires iOS 7.1 & Android 4.4 above, Bluetooth 4.0 (Smartphone only, not compatible with